EGEsoll - сборник решений задач из ЕГЭ

Задача 5 досрок

Текстовый файл состоит из заглавных букв латинского алфавита A, B, C, D, E и F.
Определите максимальное количество идущих подряд символов в прилагаемом файле, среди которых пара символов BС (в указанном порядке) встречается не более 180 раз.
Для выполнения этого задания следует написать программу.

Досрочный вариант 2026 - КЕГЭ

Download File 1

Добавлено: 17.04.26 20:45

Перейти к решению

Решение

Решение на Python:

f = open("24_28765.txt")

s = f.readline()
s = s.replace("BC", "B*C")
s = s.split("*")

maxd = 0
for i in range(len(s)):
    if len("".join(s[i:181+i])) > maxd:
        maxd = len("".join(s[i:181+i]))
print(maxd) # 38442

Ответ: 38442

Автор - rubygem17

Объяснение

None

Назад